New video player unavailable with some existing video player templates

Incident Report for StreamShark

Resolved

At 6:54 am UTC engineers completed all internal tests and verified the new player is back to normal functionality. We apologise for any disruption experienced by customers due to this issue. A post mortem report will be available in the next 24 hours.
Posted May 21, 2026 - 07:01 UTC

Monitoring

Engineers have deployed the fix and internal testing shows the issue as resolved. We will continue to monitor and close the incident if no further issues are detected.
Posted May 21, 2026 - 03:29 UTC

Identified

Our engineers have identified the cause of the new video player failing to load. Certain existing video templates contain a missing property value which prevents the new player from loading correctly. Newly created templates and the default template are not affected by this issue

Workaround: If you are experiencing this issue, switching to the default template or creating a new template will resolve it. The legacy video player also remains fully operational.

Our team is working on a fix to ensure all existing templates are compatible with the new player. We will post an update once a resolution has been deployed - ETA is ~1 hour
Posted May 21, 2026 - 01:03 UTC

Investigating

At 11:43 PM UTC our team identified an issue where the new video player is failing to load due to a compatibility issue with some existing video player templates. Our team has identified the cause and is actively working on a fix.

In the meantime, users are encouraged to use the legacy player if they are unable to load the new player
Posted May 21, 2026 - 00:54 UTC
This incident affected: Video Player.